# 配置到192.1.1.0/24网段的静态路由。
DeviceB(config)# ip route 192.1.1.0 255.255.255.0 gigabitethernet 0/1
# 启用DHCP Server功能。
DeviceB(config)# service dhcp
# 配置用户类规则。
DeviceB(config)# ip dhcp class myclass
DeviceB(config-dhcp-class)# relay agent information
DeviceB(config-dhcp-class-relayinfo)# relay-information hex 060223*
# 创建地址池并配置相关网络参数。
DeviceB(config)# ip dhcp pool pool1
DeviceB(dhcp-config)# network 192.1.1.0 255.255.255.0
DeviceB(dhcp-config)# default-router 192.1.1.1
DeviceB(dhcp-config)# dns-server 192.1.1.2
# 设置匹配用户类时分配地址网段。
DeviceB(dhcp-config)# class myclass
DeviceB(config-dhcp-pool-class)# address range 192.1.1.200 192.1.1.254
DeviceB(config-dhcp-pool-class)# exit
# 配置到192.1.1.0/24网段的静态路由。
DeviceB(config)# ip route 192.1.1.0 255.255.255.0 gigabitethernet 0/1
# 启用DHCP Server功能。
DeviceB(config)# service dhcp
# 配置地址池pool1的网络参数。
DeviceB(config)# ip dhcp pool pool1
DeviceB(dhcp-config)# network 192.1.1.0 255.255.255.0
DeviceB(dhcp-config)# default-router 192.1.1.1
DeviceB(dhcp-config)# dns-server 192.1.1.2 DeviceB(dhcp-config)# exit
(3) 配置Host启动DHCP获取地址的功能。
5. 验证配置结果
# Host申请到192.1.1.0/24网段的地址。
# 在Device B通过show ip dhcp pool命令查看地址池配置及使用情况。
DeviceB(config)# show ip dhcp pool
Pool name Total Distributed Remained Percentage
———— ———– ———– ——– ———–
pool1 126 1 125 0.99206
四、 配置文件
● Device A的配置文件
hostname DeviceA
!
interface gigabitethernet 0/1
ip address 192.1.1.1 255.255.255.0
!
interface gigabitethernet 0/2
!
service dhcp
ip helper-address 172.2.2.1
!
● Device B的配置文件
hostname DeviceB
!
interface gigabitethernet 0/1
ip address 172.2.2.1 255.255.255.0
!
ip route 192.1.1.0 255.255.255.0 gigabitethernet 0/1
service dhcp
!
ip dhcp pool pool1
network 192.1.1.0 255.255.255.0
default-router 192.1.1.1
dns-server 192.1.1.2
!
(2) 配置DNS Server
# 配置DNS Server的IP地址为192.1.1.130/25。
(3) 配置Host
# 配置Host A、Host B、Host C启动DHCP获取地址的功能。
四、验证配置结果
# Host A和Host B申请到192.1.1.0/25网段的地址。
# Host C申请到192.1.1.128/25网段的地址。
# 在Device A通过show ip dhcp pool命令查看地址池配置及使用情况。
DeviceA(config)# show ip dhcp pool
Pool name Total Distributed Remained Percentage
———— ———– ———– ——– ———–
pool1 126 2 124 0.98413
pool2 126 1 125 0.99206
五、 配置文件
Device A的配置文件
hostname DeviceA
!
interface gigabitethernet 0/1
ip address 192.1.1.1 255.255.255.128
!
interface gigabitethernet 0/2
ip address 192.1.1.129 255.255.255.128
!
service dhcp
!
ip dhcp pool pool1
network 192.1.1.0 255.255.255.128
default-router 192.1.1.1
dns-server 192.1.1.130
domain-name test.com
lease 5
!
ip dhcp pool pool2
network 192.1.1.128 255.255.255.128
default-router 192.1.1.129
dns-server 192.1.1.130
domain-name test.com
lease 3
!
# 检测到MAC地址迁移后,查看Deivce A上的记录。
DeviceA# show mac-address-table flapping record
Mac address flapping detect status : on
Mac address flapping detect interval : 1s
Mac address flapping syslog supress time : 1800s
Mac address flapping record max count : 300
Mac address flapping record total count : 2
Move-Time VLAN MAC-Address Original-Port Move-Ports Status
——————- —– ————– ————— ———— ——–
2020.11.14 12:10:46 1 0001.1111.1111 ge0/1 ge0/2 Normal
2020.11.14 12:10:58 1 0001.1111.1111 ge0/2 ge0/1 ERR-DOWN
Host13(config)# ip route 0.0.0.0 0.0.0.0 192.168.20.1
Host13(config)# interface gigabitethernet 0/1
Host13(config-if-GigabitEthernet 0/1)# no switchport
Host13(config-if-GigabitEthernet 0/1)# ip address 192.168.20.13 255.255.255.0
# 在终端上使用show ip route命令查看缺省网关。发送端和接收端都需要配置缺省网关,任何一方未配置都无法实现跨网段通信。以Host 2为例,因存在缺省路由S*0.0.0.0/0 [1/0] via 192.168.10.1,当终端需要跨网段通信时,将报文交由网关192.168.10.1转发。
Host2# show ip route
Codes: C – Connected, L – Local, S – Static
R – RIP, O – OSPF, B – BGP, I – IS-IS, V – Overflow route
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
解决方法:将聚合组和端口下的配置清空 int g1/0/X \\ X 表示端口 defult
This command will restore the default settings. Continue? [Y/N]:y quit
# int bri X \\ X 表示聚合组编号 defult
This command will restore the default settings. Continue? [Y/N]:y quit